толик147
01.10.2020 18:35

На языке PYTHON Андрей изучает социальные сети и пытается определить скрытые атрибуты пользователей по их друзьям. Поскольку Андрей - профессиональный программист, то он хочет протестировать свою программу прежде чем верить ее результатам. Но для этого требуется много разных графов, похожих на социальные сети. Андрей хочет получать графы с разным количеством пользователей (т.е. вершин графа) и разными отношениями дружбы (т.е. ребрами графа). Отношение дружбы ненаправленное. В графе не должно быть петель и кратных ребер. Андрей будет задавать желаемое количество вершин и желаемое среднее количество ребер, инцидентных вершине. Его устроит даже граф, если эти его характеристики будут отличаться от заданных, но не более чем на 20%.

Ваша программа получает на вход 2 целых положительных числа - N - количество вершин и K - среднее количество ребер у вершины (1≤ N ≤ 200, 0 ≤ K ≤ N - 1)

Программа печатает граф описанного вида. В первой строке печатается количество вершин графа. Начиная со следующей строки, печатается матрица смежности графа по строкам. Вершины нумеруются последовательно, начиная с 0. Элемент матрицы смежности равен 1, если соответствующее ребро входит в граф, и 0, иначе. Элементы разделяются пробельными символами. Элементы главной диагонал матрицы смежности должны равняться 0. Если графа описанного вида не существует, программа ничего не печатает

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Tima22890
29.12.2020 08:05
<!DOCTYPE html>
<html>
<head>
<meta charset="UTF-8">
<title>Почему так важно изучать информатику</title>
</head>
<body>
<font color=black>   
<h3 color=white><p><strong>Зачем я изучаю информатику?</strong></p></h3> <br>
<h4>В наше время это, наверно, самый главный предмет, так как сейчас все только держится на коммуникационных технологиях. Чтобы попасть на хорошо оплачиваемую работу надо иметь опыт «общения» с компьютером. Я думаю, что без этого ни как, в данный момент даже дедушки и бабушки учатся работе с компьютером. Это очень важно учить и понимать информатику и новую технику.</h4>
 <br>
<h4 align=right><strong>Вейхнер Эвелина, 7 А класс</strong></h4>
<hr></hr>
<br>
 <h4>Я думаю, что это правильно, что в нашей школе изучают предмет «Информатика». Потому что компьютеры стали важной частью человечества. Если  технологии станут быстрее развиваться, то люди поймут, что без компьютера не обойтись. Поэтому надо учить информатику.</h4>
<br>
<h4 align=right><strong>Малахов Антон,  7 Б класс</strong></h4>
 <hr></hr>
<br>
<h4>В век высоких технологий, когда в каждом доме присутствует компьютер, человек должен знать, как с ним работать. Для изучения и практического применения и нужен предмет информатика. Её преподают в школах, ВУЗах, люди ходят заниматься в школы информатики. Сначала все кажется очень  сложным, но проходит время и человека затягивает интерес. Он не понимает, как проснуться утром и не сесть за компьютер. Но это не очень хорошо. Не нужно сидеть много времени за компьютером, но и не нужно ограждать себя от сегодняшнего дня.</h4>
 <br>
 <h4 align=right><strong>Штанг Софья, 8 класс</strong></h4>
</body>
</html>
Создать сайт (лёгкий, в html) информатика 8 класс
0,0(0 оценок)
Ответ:
andreisolo18
08.01.2020 09:52
Var s,p1,p2:string;
a:array['A'..'Z'] of byte;
n,i,j,f:integer; c,sim:char;
begin
readln(n);
readln(s);
for c:='A' to 'Z' do a[c]:=0;
for i:=1 to length(s) do
 a[s[i]]:=a[s[i]]+1;
p1:=''; p2:=''; f:=0;
for c:='A' to 'Z' do
 begin
 for j:=1 to a[c] div 2 do
  begin p1:=p1+c; p2:=c+p2; end;
 if (a[c] mod 2=1)and(f=0)
  then begin sim:=c; f:=1; end;
 end;
if f=1 then p1:=p1+sim;
p1:=p1+p2;
writeln(p1);
end.

Пример:
6
QAZQAZ
AQZZQA

PS. Программа проверялась только для коротких (String) строк. Для длинных нужно использовать AnsiString.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота