katyaSekret
07.06.2022 23:11

Напишите программу на пайтоне , которая умножит сумму 5 и 6 на 10 ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
xabibullinaeliza
02.11.2020 04:58

#include <iostream>

#include <vector>

#include <algorithm>

using namespace std;

int main()

{

int s, n;

cin >> s >> n;

vector <int> a(n);

for(int i = 0; i < n; i++)

 cin >> a[i];

sort(a.begin(), a.end());

int prev_s = 0, count = 0;

for(int i = 0; i < n; i++)

 if(a[i] >= s)

 {

  prev_s = a[i];

  count++;

  for(int j = i; j < n; j++)

   if(a[j] - prev_s >= 3)

   {

    count++;

    prev_s = a[j];

   }

  break;

 }

cout << count;

return 0;

}

0,0(0 оценок)
Ответ:
cazuncko2016
21.12.2022 14:08

const N = 10;  

var a, i, count, z: integer; s:string;  

suc: array[1..N] of integer;  

begin

 Randomize();

 count := 0;  

 z := 1;

 for i := 1 to N do begin

   a := random(10, 50);

   Str(a, s); if s[2] = '4' then begin count += 1; suc[z] := a; z += 1; end;

 end;

 if count > 0 then begin for i := 1 to z-1 do begin writeln('Выиграшное число: ', suc[i]); end;  

 Writeln('Всего выиграшных билетов: ', count, ' из ', N); end  

 else Writeln('Нет ни одного выиграшного билета');

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота