aidana200257
09.08.2020 00:49

Обязательно на basic! Составить программу ввода величины T- времени в течение суток, и выдачи текста:
«Вы уже проснулись?», если t<10;
«Не пора ли обедать?», если t=12;
«Еще не вечер!», если t>=18;
«Как работается?», в остальных случаях.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Света20177
20.07.2020 15:11

440

Определим количество символов в алфавите, которым кодируется пароль. По условию он состоит из 10 букв, 10 цифр ( от 0 до 9 ) и 5 специальных символов. Итого N=10+10+5 = 25

Определим информационный объем одного символа  i из формулы N=2^i  По условию все символы кодируют одинаковым и минимально возможным количеством бит.  

2⁴ ≤ i ≤ 2 ⁵   ⇒ i= 5 бит

Пароль состоит из 10 символов, значит его объем I = i*k= 5*10 = 50 бит, но по условию задачи на хранение как пароля, так и дополнительных сведений отведено одинаковое для каждого пользователя целое количество байт. Ближайшее к 50 число кратное 8 равно 56.

таким образом информационный объем пароля I = 56/8=7 байт

Но так как по условию  для хранения пароля выделено в байтах в 1,5 раза меньше памяти, чем для хранения дополнительных сведений, то  размеры  пароля и дополнительных сведений в соотношении  1 к 1,5

верны при значениях 8 и 12 байт  

Итого на одного пользователя выделено 8+12 = 20 байт

Для 22 пользователей: 22*20= 440 байт

Объяснение:

0,0(0 оценок)
Ответ:
fire31
12.08.2021 18:59
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  var a:=MatrixRandom(7,7,0,9);
  var k:=0;
  for var i:=0 to 6 do begin
    for var j:=0 to 6 do begin
      Write(a[i,j]:3);
      if a[i,j] in [1..5] then Inc(k)
      end;
    Writeln
    end;
  Writeln('Кол-во элементов на [1,5]: ',k)
end.

Тестовое решение:
  2  1  7  3  3  2  7
  9  2  9  2  0  5  5
  4  2  6  9  4  6  0
  1  0  3  5  4  5  9
  6  3  6  0  2  0  8
  0  8  4  3  2  1  8
  6  0  4  4  5  4  0
Кол-во элементов на [1,5]: 27

Вариант "совсем для школы"

const
  n=7;
var
  a:array[1..n,1..n] of integer;
  i,j,k:integer;
begin
  Randomize;
  k:=0;
  for i:=1 to n do begin
    for j:=1 to n do begin
      a[i,j]:=Random(10);
      Write(a[i,j]:3);
      if a[i,j] in [1..5] then Inc(k)
      end;
    Writeln
    end;
  Writeln('Кол-во элементов на [1,5]: ',k)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота