ник5024
23.12.2022 03:51

Написать программу в паскале, которая формирует матрицу nXn в следующем виде: У меня есть программа, которая формирует матрицу в виде:
1 1 1 1 1 1 1 1 1 1
2 2 2 2 2 2 2 2 2 1
3 3 3 3 3 3 3 3 2 1
4 4 4 4 4 4 4 3 2 1
5 5 5 5 5 5 4 3 2 1
6 6 6 6 6 5 4 3 2 1
7 7 7 7 6 5 4 3 2 1
8 8 8 7 6 5 4 3 2 1
9 9 8 7 6 5 4 3 2 1
10 9 8 7 6 5 4 3 2 1
И программа для нее:
var
n,i,j: integer;
a: array[1..20,1..20] of integer;
begin
write('Введите размерность матрицы');
readln(n);
for i:=1 to n do
begin
for j:=1 to n do
begin
if i+j a[i,j]:=n-j+1;
write(a[i,j]:4);
end;
writeln;
end;
end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
aaa1616
25.04.2022 06:52
Все объекты на Рабочем столе можно разделить на 3 группы: ярлыки,файлы,папки.Сведения о файле, папке или ярлыке можно найти в пункте меню Пуск справка и поддержка.Окно-это прямоугольная область экрана, в которой выводится определенная информация: содержимое дисков, программы, создаваемые пользователем документы, запросы и сообщения Windows. Окна можно открывать (разворачивать), закрывать, сворачивать, перемещать, упорядочивать, менять размеры . Открытое окно может занимать целый экран или его часть.Управлять размерами окна можно плавно с мыши и автоматически - с
0,0(0 оценок)
Ответ:
daaaasha2018
23.02.2023 10:17
{Данная программа переводит любое сочетание символов ASCII в систему счисления заданную пользователем.}

//Pascal ABC.NET v3.0 сборка 1111

var
 a,i,b,r,n,j,bug:integer;
 s,se,slo,slof:string;

procedure preob(var a,b,n:integer; var se:string);
 begin
  repeat
   b:=a mod n;
   a:=a div n;
   str(b,se);
   s+=se;
  until (a<=n-1);
 end;

beginreadln(slo);
readln(n);
for j:=1 to length(slo) do
begin;
a:=ord(slo[j]);
preob(a,b,n,se);
str(a,se);
s+=se;
for i:=1 to length(s) div 2 do
begin;
se:=s[i];
s[i]:=s[length(s)-i+1];
s[length(s)-i+1]:=se[1];
end;
write(s,'-');
slof:=slof+s;
delete(s,1,length(s));
end;
end.

Пример ввода:
Домашняя работа на завтра.
2
Пример вывода:
11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-

{Таким образом, фразу "Домашняя работа на завтра." можно закодировать как "11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-".}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота