24j18g81B
10.08.2020 04:31

Дана программа: НАЧАЛО
ПОКА нашлось (01) ИЛИ нашлось (02) ИЛИ нашлось (03)
заменить (01, 103)
заменить (02, 10)
заменить (03, 210)
КОНЕЦ ПОКА
КОНЕЦ
Известно, что исходная строка начинается с цифры 0, а далее содержит
12 цифр 1, 15 цифр 2 и 17 цифр 3, расположенных в произвольном порядке.
Сколько цифр 2 будет в строке, которая получится после выполнения данной
программы?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dmitriy14nagiev
10.05.2022 16:20

Не знаю на каком языке надо было, но сделал на языке Pascal

1.

var s:string;

k,i:integer;

begin

 readln(s);

 k := length(s);

 writeln(k);

end.

2.

var a,b:string;

i:integer;

begin

 writeln('Введите первую фамилию');

 readln(a);

 writeln('Введите вторую фамилию');

 readln(b);

 i:=length(a)-length(b);

 if i>0 then

   writeln('Первая фамилия длиннее')

 else writeln('Вторая фамилия длиннее')

end.

еще как вариант второго номера:

var a,b:string;

i:integer;

begin

 writeln('Введите первую фамилию');

 readln(a);

 writeln('Введите вторую фамилию');

 readln(b);

 i:=length(a)-length(b);

 if i>0 then

   writeln('Фамилия ', a, ' длиннее фамилии ', b)

 else writeln('Фамилия ', b, ' длиннее фамилии ', a)

end.

0,0(0 оценок)
Ответ:
polina120805
26.01.2021 04:45

# Пусть белый цвет это false и соответственно черный true

эта функция определяет цвет по ее координатам, которые не больше числа 8

def checkColor(x, y):

   assert x <= 8 and y <= 8

   color = None

   if x % 2 == 0:

       if y % 2 == 0:

           color = True

       else:

           color = False

   else:

       if y % 2 == 0:

           color = False

       else:

           color = True

   return color

# Задаем координаты первой и второй позиции

k, l, m, n = map(int, input().split())

if checkColor(k, l) == checkColor(m, n):

   print('YES')

else:

   print('NO')

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота