Судзуми777
30.05.2020 22:10

Информатика.паскаль.дано натуральное число n. составить программу, которая определяет, сколько цифр этого числа кратны трем. p.s т.е мало того что нам нужно определить кратность каждой цифры этого числа ина выходе получит сколько этих чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dania7834
11.06.2020 13:57

var

  N, count:integer;

begin

   write('N = ');

  readln(N);

  count := 0;

  while N > 0 do

  begin

    if (N mod 10) mod 3 = 0 then

      count := count + 1;

    N := N div 10;

  end;

  writeln('Count = ', count);

  readln;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота