mahachik7
10.07.2021 13:01

Паскаль! Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число - сумму чисел, кратных 3.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ElizavetaArtLove13
22.06.2022 02:27

Автор — творец всякого литературного, музыкального или любого художественного произведения и вообще всякого произведения ума, воплощённого искусством. Помимо этого, под автором понимают создателя чисто научных работ, кода программного обеспечения, а также любых иных текстов.

Авторское право является формой защиты авторов и субъектов авторского права, предусмотренных Конституцией Украины и другими нормативно-правовыми актами, связанными с созданием и использованием произведений. Авторское право защищает как опубликованные, так и не выпущенные в свет произведения.

Если вы что-то создаете: книгу, инструкцию, чертежи — вы автор и ваши авторские права охраняет четвертая часть Гражданского кодекса.

 Закон защищает автора с момента создания творения. Чтобы стать автором, не надо платить госпошлину, заполнять заявления и стоять в очереди. Создайте что-нибудь и будьте автором.

Что считать «созданием», в законе четко не сказано, но есть оговорка, что это результат творческого труда. В юридической практике так:

Создал = поработал головой и руками.

0,0(0 оценок)
Ответ:
naletova1974
18.06.2022 18:03

1:

print(hex(int(input()))[2:].upper())

Объяснение:

int(input()) ввод числа

hex(x) перевод числа из 10 в 16 с.с. в таком виде 15(10) -> 0xf(16)

[2:] отсекает первые два символа(0x)(просто знай, что они не нужны)

.upper() метод строки, делающий из f -> F

2-ое задание это часть 3-его, поэтому код один и тот же:

alphabet = ''

def now_system_10(x):

   global new_system

   znak = '+'

   if x < 0:

       x = abs(x)

       znak = '-'

   new_x = ''

   lst = []

   while x >= new_system or lst == []:

       if 9 < x % new_system:

           if x % new_system < 20:

               lst += [alphabet[int(str(x % new_system)[1])]]

           elif x % new_system < 30:

               lst += [alphabet[int('1' + str(x % new_system)[1])]]

           else:

               lst += [alphabet[int('2' + str(x % new_system)[1])]]

       else:

           lst += [x % new_system]

       x //= new_system

   if x != 0:

       lst += [x]

   lst.reverse()

   if znak == '-':

       new_x += '-'

   for j in lst:

       new_x += str(j)

   return new_x

num, new_system = map(int, input().split())

print(now_system_10(num))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота