annapalko044
25.01.2021 00:37

Написать программу, вводящую с клавиатуры целые числа и вычисляющую их сумму до тех пор, пока эта сумма не станет больше 1000. В этом случае программа должна напечатать вычисленную сумму и завершиться. (С программы Java)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
combatcat
29.11.2020 12:02

import java.util.Scanner;

public class Main{

   public static void main(String[] args) {

       Scanner sc = new Scanner(System.in);

       int sum = 0, x;

       while(sum <= 1000){

           x = sc.nextInt();

           sum = sum + x;

       }

       System.out.println(sum);

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота