Блинь
01.06.2021 05:18

написать программу на С++. Пользователь вводит число а. Нужно, чтобы программа определила положительно ли число, если да, то: 1) посчитать сколько разрядов в этом числе;

2) определить каких разрядов больше: со значением от 0 до 4 или от 5 до 9.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
DanilKrut11
28.11.2020 23:08

#include <iostream>

using namespace std;

int main() {

setlocale(LC_ALL, "Russian");

string a;

cin >> a;

if(stoi(a)>=0) {

cout << a.length() << " разрядов";

} else {

cout << "Wrong data";

перефразировать вторую часть задания, исправлю. Какое значение?

}

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота