ОЛДВЖ
25.06.2022 23:38

Используя язык программирования QBasic, составьте программу, которая выведет на экран ваши фамилию, имя, отчество и номер группы так, чтобы каждое слово находилось в отдельном углу экрана. Используйте операторы PRINT и LOCATE (для набора теста используйте символы английского алфавита). текст программы предоставьте в качестве ответа

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ivolapseb
01.07.2020 17:57
Выполняя алгоритм, получаем следующий результат (15 итераций)

1. 0..65534 -> 32767
2. 0..32766 -> 16383
3. 0..16382 -> 8191
4. 0..8190  -> 4095
5. 0..4094  -> 2047
6. 2048..4094 -> 3071
7. 2048..3070 -> 2559
8. 2560..3070 -> 2815
9. 2816..3070 -> 2943
10. 2944..3070 -> 3007
11. 2944..3006 -> 2975
12. 2976..3006 -> 2991
13. 2992..3006 -> 2999
14. 3000..3006 -> 3003
15. 3000..3002 -> 3001

Если лень перебирать вручную, можно воспользоваться программой

var k,l,r,x,f:integer;
begin
f := 3001;
l := 0;
r := 65534;
x := (l + r) div 2;
k := 1;
while (x <> f) and (l < r) do
  begin
  writeln(k,' ',l,' ',r,' ',x);
  k := k + 1;
  if f < x then r := x - 1
    else l := x + 1;
  x := (l + r) div 2
  end;
writeln(k,' ',l,' ',r,' ',x);
end.
0,0(0 оценок)
Ответ:
NananaAD
13.06.2020 19:18
По выполняемым функциям и возможности применения информационные технологии делят на используемые:1) в автономных компьютерах (ПЭВМ) и в локальных рабочих станциях (АРМ) в составе сетевых автоматизированных информационных систем (АИС) реального времени;2) в объектно-ориентированных, распределённых, корпоративных и иных локальных и сетевых информационно-поисковых, гипертекстовых и мультимедийных системах;3) в системах с искусственным интеллектом;4) в интегрированных АИС;5) в геоинформационных, глобальных и других системах.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота