nurbibisaidova3
28.05.2022 03:17

Составьте программу, заменяющую меньшее из двух данных чисел на среднее арифметическое этих чисел,а большее из двух данных чисел на среднюю этих чисел help ! please

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
milamilmi
11.06.2020 08:51

program lkcfndsl;

uses crt;

var a,b,s,g:real;

begin

clrscr;

readln(a,b);

s:=(a+b)/2;

g:=sqrt(a*b);

if a>b then a:=g else a:=s;

if b>a then b:=g else b:=s;

writeln(a,b);

readln;

end.

Надеюсь так понял.

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота