linnik4Platon
08.04.2021 03:04

Паскаль. составить программу вычисления площади треугольника по любой из 3 известных формул(в программе должны использоваться все 3 на выбор). сами формулы пишу уже 2-ой раз!

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
jasulau
11.06.2020 07:07

var S,a,b,c,p,p1,h:real;
k:integer;
begin
write('Kakoy sposob viberem(1,2,3)?');
read(k);
if k=1 then begin
writeln('Vvedite a,h');
read(a,h);
S:=(a*h)/2;
end;
if k=2 then begin
writeln('Vvedite a,b,c');
read(a,b,c);
S:=(Sin(c*Pi/180)*a*b)/2;
end;
if k=3 then begin
writeln('Vvedite a,b,c');
read(a,b,c);
p1:=1/2*(a+b+c);
S:=sqrt(p1*(p1-a)*(p1-b)*(p1-c));
end;
writeln(S);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота