HamstersLOKKI
08.02.2023 05:07

Питон! Дан фрагмент текста, Запрашиваемый у пользователя. Написать программу, находящую наибольшее количество цифр, идущих в нём подряд.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
hudia4
26.11.2020 20:50

#!/usr/bin/env python3

import sys

 

text = sys.argv[1]

maxSequenceStart = -1

maxSequenceLength = 0

currentSequenceStart = -1

currentSequenceLength = 0

insideSequence = False

 

for pos, ch in enumerate(text):

   if ch.isdigit():

       if not insideSequence:

           currentSequenceStart = pos

           currentSequenceLength = 1

           insideSequence = True

       else:

           currentSequenceLength += 1

   else:

       if insideSequence:

           insideSequence = False

           if currentSequenceLength > maxSequenceLength:

               maxSequenceStart = currentSequenceStart

               maxSequenceLength = currentSequenceLength

if insideSequence and currentSequenceLength > maxSequenceLength:

   maxSequenceStart = currentSequenceStart

   maxSequenceLength = currentSequenceLength

 

if maxSequenceStart < 0:

   print("No digits in this text!")

else:

   print("Longest digits sequence starts from index", maxSequenceStart,

         "and has length of", maxSequenceLength, "digits")

$ ./max_digits_sequence.py "123 12 1234"

Longest digits sequence starts from index 7 and has length of 4 digits

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота