Нюся5012
20.06.2020 13:00

Написать программу( желательно си++). Дана непустая последовательность литер, оканчивающаяся точкой.Определить, удовлетворяет ли она следующему свойству: последовательность совпадает с каким-то отрезком ряда 0123456789

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mashaaa98
26.11.2020 11:05

#include <iostream>

using namespace std;

int main() {

string s;

string ss("0123456789");

getline(cin, s);

if(s[s.length()-1!='.']) {

 s+=".";

}

string temp;

for(int i = 0; i<ss.length(); ++i) {

 temp+=ss[i];

 if(s.find(temp)!=-1) {

  cout << "yes";

 return 0;

 }

}

cout << "no";

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота