Кирилл11221
19.03.2021 01:54

Найти среднее каждого столбца матрицы b(n*m) написать программу на c#

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
KPY3
22.02.2021 22:13

Відповідь:

Пояснення:

Алгоритмы, в которых команды выполняются последовательно одна за другой, в порядке их записи, называются линейными.

 

 Пример 1. Написать алгоритм получения изображения двузначного числа  с исполнителя Чертежник.

Выберем следующий алгоритм построения изображения:

1) создать поле для исполнителя Чертежник размером 6х5 (6 клеток по горизонтали, 5 клеток по вертикали);

2) сместиться в точку (2, 2);

3) опустить перо;

4) изобразить цифру 1;

5) поднять перо и смечтиться в точку (4,3);

6) опустить перо;

7) изобразить цифру 2;

8) поднять перо и перейти в начало координат.

 

Вначале запишем алгоритм решения задачи на русском языке. Затем для каждой команды этого алгоритма выберем соответствующую команду исполнителя Чертежник.

Запись алгоритма на русском языке Текст программы

Заголовок программы;

Program PR_1;

вызов исп. Чертежник;

uses Drawman;

начало программы;

begin

создание поля размером 6х5;

Field(6,5);

рисуем цифры 1 и 2;

ToPoint(2,2);PenDown;

ToPoint(3,3);

ToPoint(3,1);

PenUp;

ToPoint (4,3);

PenDown;

ToPoint(5,3);

ToPoint(5,2);

ToPoint(4,1);

ToPoint(5,1);

PenUp;

ToPoint (0,0);

закончить программу.

end.

Можешь загрузить!        Пример 1

Для выполнения программы выберем команды ПрограммаàВыполнить (F9 или кнопка  на панели инструментов). Откроется окно исполнителя Чертежник, где нужно нажать кнопку Пуск или клавишу Enter на клавиатуре.

Команда OnVector(a,b)

OnVector(a,b)– перемещает перо Чертежника на вектор (a,b).

Выполним пример 1, но вместо команды ToPoint(x,y),  кторая перемещает перо Чертежника в точку (x,y). будем использовать OnVector(a,b).

Перемещение из точки (1,2) в точку (3,3) с вектора: OnVector(2,1).

Перемещение из точки (3,3) в точку  (1,2) с вектора: OnVector(-2,-1).

Перемещение из точки (1,3) в точку  (4,3) с вектора: OnVector(3,0).

Перемещение из точки (4,3) в точку (1,3)  с вектора: OnVector(-3,0).

Перемещение из точки (3,2) в точку (3,5)  с вектора: OnVector(0,3).

Перемещение из точки (3,5) в точку (3,2)  с вектора: OnVector(0,-3).

 

 Пример 2. Написать алгоритм получения изображения двузначного числа  с исполнителя Чертежник, используя команду OnVector(a,b).

0,0(0 оценок)
Ответ:
Mrrezed
26.04.2023 22:57

java

import java.util.random;

public class myapp{

  public static void main (string {

    random rand = new random();

    int n = rand.nextint(50);

    int [] arr = new int[n];

    for(int i = 0; i < n; i++) {

      int j = rand.nextint(50);

      arr[i] = j;

    }

    for( int i = 0; i < n; i++) {

      if ( arr[i] % 2 == 0 ) {

        system.out.print(arr[i] + " ");

      }

    }

  }

}

pascal

program myapp;

var

  i, n , j: integer;

  arr: array of integer;

begin

randomize;

n : = random(50);

setlength(arr, n);

for i: = 0 to n do

  begin

    j: = random(50);

    arr[i]: = j;

  end;

for i: = 0 to n do

  begin

    if( arr[i] mod 2 = 0 ) then

      begin

        write(arr[i], ' ');

      end;

  end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота