Мир666ад
22.05.2022 18:26

составить программу в Паскале которая по введенным данным сторон смогла отвечать, является ли треугольник равносторонним, равнобедренным или разносторонним ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Vonder239142
30.04.2021 02:53

1. Чтобы решить задачу, надо определить, какое количество варенья съест Машенька за 20 дней. Вначале вычислим это количество в ложках, если известно, что за день она съедает по 5 ложек варенья:

5 * 20 = 100 ложек.

2. Теперь переведем 100 ложек варенья в граммы, если известно, что каждая ложка помещает 5 г варенья:

100 * 5 = 500 грамм.

3. Если исходное количество варенья составляет 650 грамм, тогда вычтем из этой массы ту часть, что съест Машенька за 20 дней и получим массу оставшегося варенья через 20 дней:

650 - 500 = 150 грамм.

ответ: получили, что через 20 дней в банке останется всего 150 грамм варенья.

0,0(0 оценок)
Ответ:
rutasolntseva
15.08.2022 15:18

ответ:

. в нужно вывести все составные числа из промежутка [2; n]. код программы:

program lab3;

var i,n,j,s,l: integer;

m: real;

begin

readln (n);

for i: =2 to n do

begin

s: =trunc (sqrt (i));

for l: =2 to s do

begin

m: = i mod l;

if m=0 then

write (' ',i);

end;

end;

end.

но проблема - как только s становится больше 2, составные числа начинают несколько раз повторятся, т.к., например 12 делится и на 2 и на 3. вопрос: как мне сделать выход из цикла после первого успешного деления?

var

i, n, j, s, l: integer;

m: real;

begin

readln(n);

for i : = 2 to n do

begin

s : = trunc(sqrt(i));

for l : = 2 to s do

begin

m : = i mod l;

if m = 0 then

begin

write(' ', i);

break;

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота