BegimaiAnarkulova
05.02.2021 17:35

надо сделать на паскале. Задание на фото​


надо сделать на паскале. Задание на фото​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
maxcarleson1
16.04.2020 14:28

Відповідь:

1)известны данные о мощности двигателей 20 моделей легковых автомобилей выясните есть ли среди них модель мощность двигателя который превышает 200 л.с.

#include <iostream>

using namespace std;

int main(){

setlocale(LC_ALL , "Rus");

int input;

for(int i = 1; i < 20; i++){

 cout << "Введите мощность " << i << " автомобиля: ";

 cin >> input;

 if(input > 200){

  cout << "Автомобиль " << i << " Превышает мощность двигателя в 200 л.с" << endl;

 }

}

return 0;

}

Напечатайте минимальное число больше 200 которое должно делиться на 17

#include <iostream>

using namespace std;

int main(){

setlocale(LC_ALL , "Rus");

for(int i = 200;;i++){

 if(i % 17 == 0){

  cout << "Число " << i << " больше 200 и минимальное которое делиться на 17" << endl;

  break;

 }

}

return 0;

}

Известны данные о температуре воздуха в селе Бурабай в течение месяца .Определите сколько раз температура опускалась ниже 0 градусов

#include <iostream>

using namespace std;

int main(){

setlocale(LC_ALL , "Rus");

int temp,counter = 0;

for(int days = 1; days <= 30; days++){

 cout << "Введите температуру в " << days << " день: ";

 cin >> temp;

 if(temp < 0){

  counter++;

 }

}

cout << "Температура опускалась ниже 0 " << counter << " раз." << endl;

return 0;

}

0,0(0 оценок)
Ответ:
povshedna
30.01.2020 20:56

pascal

Объяснение:

var i, n, mysign, nsign: integer;

   ismon: boolean;

   a: array of integer;

begin

 Write('Введите размер массива: '); ReadLn(n);

 SetLength(a, n);

 WriteLn('Введите Элементы массива: ');

 for i := 0 to n - 1 do ReadLn(a[i]);

 mysign := sign(a[1] - a[0]);

 if mysign >= 0 then mysign := 1;

 ismon := true;

 for i := 2 to n - 1 do

 begin

   nsign := sign(a[i] - a[i - 1]);

   if nsign >= 0 then nsign := 1;

   if nsign <> mysign then ismon := false;

 end;

 if ismon then WriteLn('Массив монотонный') else WriteLn('Массив не монотонный');

 

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота