fomax1337
23.05.2021 11:51

Водномерном массиве а(к) хранятся результаты социологического опроса, напишите программу для подсчета кол-ва результатов отклоняющихся от среднего не более чем на 7% кол-во людей: 200. [0; 100]случайные числа( которые ставят люди). программа должна быть написанна для visual basic.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Lokator505
11.06.2020 04:05

using System;
using System.Linq;

namespace Interesting {
    class Program {
        static void Main(params int[] a) {
            int n = 0;
            foreach (int i in a) {
                n += (Math.Abs(i - a.Average()) / 100 <= 0.07) ? 1 : 0;
            }
            Console.WriteLine(n);
        }
    }
}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота