KatyaKuxar
08.08.2021 18:24

15. Написать программу, которая после введенного с клавиатуры числа в диапазоне от 1 до 999, обозначающего денежную единицу, дописывает слово “рубль” в правильной форме. Например, 12 рублей, 21 рубль и т.д. Рекоменду-ется использовать оператор “Case”. Вычисления организовать в цикле, т.е. после печати одного значения программа должна вывести запрос: “закончить рабо-ту?”. При отрицательном ответе вводятся следующие данные и т.д. При органи-зации цикла операторы цикла не использовать.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vasipovismail
08.11.2020 02:53
Var
    s: string;
    a, b: integer;
begin
    readln(s);
    if s[1] = 'x' then begin
        a := StrToInt(s[3]);
        b := StrToInt(s[5]);
        if s[2] = '-' then a := -a;
        writeln(b - a);
    end
    else if s[3] = 'x' then begin
        a := StrToInt(s[1]);
        b := StrToInt(s[5]);
        if s[2] = '-' then begin
            a := -a;
            b := -b;
        end;
        writeln(b - a);
    end
    else if s[5] = 'x' then begin
        a := StrToInt(s[1]);
        b := StrToInt(s[3]);
        if s[2] = '-' then
            b := -b;
        writeln(a + b);
    end
end.

учтите что никакой защиты от дурака или неверного ввода
0,0(0 оценок)
Ответ:
20042007rbn
30.01.2020 01:43
Class Sort25{
 public static void main(String[] args) throws java.io.IOException{
  int c, n = 0, array[];
  while((c = System.in.read())==13 || (47<c && c<58 && (n = n*10+c-48)>-1));
  if(25<n || c!=10)return;
  array = new int[n];
  for(c = 0; c<n; c++){
   int d = 0; boolean negative = false;
   while((d = System.in.read())!=10)
    if(47<d && d<58)array[c] = array[c]*10+d-48;
    else if(d==45)negative = true;
   if(negative)array[c]*=-1;
  }
  sortArray(array);
  for(c = 0; c<n; c++)System.out.print(array[c]+" ");
 }
 private static void sortArray(int[] array){
  for(int c = 0; c<array.length-1; c++){
   int b = c, e;
   for(int d = c+1; d<array.length; d++)
    if(array[d]>array[b])b=d;
   e = array[c];
   array[c] = array[b];
   array[b] = e;
  }
 }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота