Nastenok122
20.04.2020 19:28

нарисовать блок схему по данному заданию Составить программу упорядочивания трех чисел x, y, z по возрастанию.
если что вот алгоритм программы
var x, y, z : integer;
begin
Writeln('Введите значения X Y Z: ');
Readln(x, y, z);
if x > Y then
begin
x := x + Y;
x := x - Y;
x := x - Y;
end;
if Y > Z then
begin
Y := y + z;
z := Y - z;
y := y - z;
end;
if x > y then
begin
x := x + y;
y := x - y;
x := x - y;
end;
writeln('X=',x, 'Y=',y, 'Z=',z);
end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
fwooper
01.04.2020 15:41

использовать Робот

алг

нач

нц пока слева стена

 закрасить

 вверх

кц

нц пока справа свободно

 закрасить

 вправо

кц

нц пока справа стена

 закрасить

 вверх

кц

вниз

кон

использовать Робот

алг

нач

нц пока снизу свободно

 вниз

кц

нц пока снизу стена

 влево

кц

вниз

нц пока справа свободно

 вправо

 если сверху стена то закрасить все

кц

нц пока слева свободно

 нц пока клетка чистая

   если слева свободно то влево

     иначе стоп все

   нц пока клетка закрашена

     нц пока снизу свободно

       вниз

       закрасить

     кц

     нц пока сверху свободно

       вверх

     кц

     влево

   кц

 кц

кц

кон

использовать Робот

алг

нач

нц пока справа свободно

 вправо

кц

нц пока справа стена

 вверх

кц

вправо

нц пока снизу свободно

 вниз

 закрасить

кц

нц пока снизу стена

 закрасить

вправо

кц

кон

Объяснение:

надеюсь без скинов норм

0,0(0 оценок)
Ответ:
milanakpoplove
07.04.2022 15:43
ответ:Задание 2 Базовое ПО содержит в себе минимальный набор средств обеспечивающих работу компьютера: операционная система; операционная оболочка; сетевая операционная система. Сервисное ПО - это програмиы, и программные комплексы которые расширяют возможности базового ПО, и организовывают более удобную работу компьютера для пользователя: программы диагностики работо компьютера; антивирусные программы; програмиы обслуживания дисков; програмиы архивирования данных; програмиы обслуживания сети. Сервисное ПО можно приобрести отдельно от компьютера, базовое же уже встроено в компьютер, сервисное ПО обеспечивает более комфортную систему компьютера для пользователя, открывает больше возможностей. Объяснение:Поставь лайк ;)лайк - плюс респект∞
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота