dim10102806
04.10.2022 16:49

Написать программу для паскаль


Написать программу для паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MashaBelous
20.11.2022 07:32

1)

var i, S, N: integer;

begin

 writeln('Введите N:');

 readln(N);

 repeat

 if i mod 2=0 then S:=S+i;;

 inc(i)

 until i>n;

 writeln('Сумма всех четных чисел 1 до ',N,' равна: ',S);

 readln;

End.

2)

var i, S, N: integer;

begin

 writeln('Введите N:');

 readln(N);

 while i<=N do

 begin

   if i mod 2=0 then S:=S+i;

   i:=i+1;

 end;

 writeln('Сумма всех четных чисел 1 до ',N,' равна: ',S);

end.

3)

var i, S, N: integer;

begin

 writeln('Введите N:');

 readln(N);

 for i:=1 to N do

   if i mod 2=0 then S:=S+i;

 writeln('Сумма всех четных чисел 1 до ',N,' равна: ',S);

end.

0,0(0 оценок)
Ответ:
Mimishichka
09.02.2020 20:45

#include <iostream>

#include <vector>

using namespace std;

#define ll long long

#define ld long double

signed main(){

   ll n,m;

   cin >> n >> m;

   vector<pair<ll,ll>> v;

   ll cur_min = LLONG_MAX;

   for(ll i = 0; i < n; i++)

       for(ll j = 0; j < m; j++){

           ll x;

           cin >> x;

           if(x < cur_min){

               v.clear();

               v.push_back({i,j});

               cur_min = x;

           }

           else if(x == cur_min)

               v.push_back({i,j});

       }

   for(auto i: v)

       cout << i.first << " " << i.second << "\n";

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота