Olga5513
09.10.2021 06:15

Написать программу на СИ : Дано целое число. Определить, одинаковы ли все цифры в десятичной записи этого числа

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:

Сам написал, сам же и пояснять буду :D

def convert_to_oct(dec_integer): #Обявляем функцию с именем _convert_to_oct_, принимающую 1 аргумент, в теле функции именованый как dec_integer (десятичное_целое)

   return oct(dec_integer)[2::] #Возвращаем восьмиричную запись десятичного числа, переданного функции. Т.к восьмиричное число в python храниться как строка, сделаем срез, убрав первые 2 символа, в которых указана СС. (пример: oct(какое_то_десятичное) -> 0o456. А нам нужно только само число - 456)

print(convert_to_oct(int(input( #Печатаем возвращённое функцией значение. В качестве аргумента к функции улетает целое десятичное число, считываемое с клавиатуры

Объяснение:

0,0(0 оценок)
Ответ:
helpme163
26.12.2021 10:33

1 текст:     

 

(Буква)      (Десятичный код)     (код)

 

 

    С                      243                            11110011

     у                      213                            11010101

    а                      193                             11000001

                           206                            11001110

   ( - )                    45                              00101101

                           208                            11010000

    а                      193                             11000001

                          206                             11001110

 

 

 

2 текст:         (Англ.яз)

 

 

(Буква)            (Десятичный код)     (Двоичный код)

 

 

   I                         73                                01001001 

  B                        66                                01000010

  M                        77                                01001101

 

 

 

 Примечания: ответы даны на ПОКАЗАННЫЕ Вами буквы и знаки.

( - )  - обозначение дефиса.

Английские буквы не кодируются в КОИ-8, используют (не беспокойтесь, это совершенно правильный подход).

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота