Asika11
13.10.2021 18:09

Напишите программу буквы(алгоритм) «н» , «Р» с рисунком.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alinarostova66
08.10.2022 07:18
Приведенная программа принимает целые числа и выводит два значения: a - количество цифр в числе и b - произведение цифр, составляющих число. При вводе нуля программа завершает работу.  Ввод отрицательных чисел игнорируется.
1) При исполнении этой программы на экран было сначала выведено число 2, затем число 15. НАИМЕНЬШЕЕ значение переменной x, для которого это возможно, равно С) 35
Здесь количество цифр равно двум, а их произведение равно 15. Число 15 представимо в виде произведения двух однозначных чисел только в виде 3х5 или 5х3. Следовательно, наименьшим числом могло быть только 35.
2) При исполнении этой программы на экран было сначала выведено число 2, затем число 15. НАИБОЛЬШЕЕ значение переменной x, для которого это возможно, равно B) 53
Решение аналогично предыдущему, но выбирается наибольшее число, т.е. 53.
3) НАИМЕНЬШЕЕ значение переменной b, которое может быть выведено на экран этой программой, равно Е) 0
Минимальное значение произведения n однозначных чисел будет равно нулю, если среди этих чисел встретить хотя бы один ноль.
4) При исполнении этой программы на экран было сначала выведено число 2. НАИБОЛЬШЕЕ значение переменной b, которое может быть выведено на экран, равно А) 81
Максимальное произведение двух однозначных чисел равно 9х9=81.
5) НАИМЕНЬШЕЕ значение переменной a, которое может быть выведено на экран этой программой, равно D) 1
Понятно, что чисел с количеством знаков, меньшим единицы, быть не может.
0,0(0 оценок)
Ответ:
Катя111111177796
24.09.2021 14:56

stdout:

/temp/compiling/source.bas(1) error 3: Expected End-of-Line, found 'Pascal'

Pascal;

^

/temp/compiling/source.bas(2) error 10: Expected '=', found ';'

Var;

  ^

/temp/compiling/source.bas(3) error 3: Expected End-of-Line, found '�'

   a,b:integer;

^

/temp/compiling/source.bas(4) error 10: Expected '=', found ';'

Begin;

    ^

/temp/compiling/source.bas(5) error 3: Expected End-of-Line, found '�'

   read(a,b);

^

/temp/compiling/source.bas(6) error 3: Expected End-of-Line, found '�'

   write(a+b);

^

/temp/compiling/source.bas(7) error 10: Expected '='

End.

^

/temp/compiling/source.bas(9) error 3: Expected End-of-Line, found '�'

Язык C++

^

/temp/compiling/source.bas(11) error 145: Only valid in -lang fb or deprecated or fblite, found 'using'

using namespace std;

^

/temp/compiling/source.bas(12) error 6: Expected '(', found 'main'

int main() {

   ^

/temp/compiling/source.bas(12) error 132: Too many errors, exiting

stderr:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота