Sveta1314
22.01.2023 22:01

Написать программу, , . вид экрана: введите числа. для завершения последовательности нажмите ноль. 45 23 15 0 введено чисел: 3 сумма чисел: 83 среднее арифметическое: 27.67

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Sashattop
11.06.2020 03:29

 

 

 

В задании не сказанно что числа целые  поэтому тип c: real;

 

 Program SumAndAvg;  

 Uses crt;
var n:integer;
c,s,m:real;
begin
clrscr;
write('Input Numbers:');
n:=0;s:=0;
repeat

read(c);
if (c>0) then
begin
n:=n+1;
s:=s+c;
end;

until (c=0);
writeln('Numbers count =',n);
writeln('Summa =',s:2:2);
writeln('Average Value=',s/n:2:2);
readkey;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота