manfork
03.03.2020 23:46

Паскаль. написать программу вычисления произведения n чисел то есть 1*2*3**n,причем, если n=0, то произведение равно 1.число множителей не должно превышать 33.при вводе числа более 33, сообщить об ошибке и повторить ввод.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ангелинка2007
11.06.2020 01:37

программа не будет давать верный ответ при n>20 т.к. нет такого целочисленного типа переменных. uint64-самый большой из всех

 

var
i, n, p: uint64;
a: array [1..10000] of integer;
begin
read(n);
p:=1;
for i:=1 to n do
begin
a[i]:=i;
p:=p*a[i];
end;
if n>33 then
writeln('eror')
else
if n=0 then
writeln('p=1')
else
writeln('p=',p);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота