кэтлин2005
26.01.2020 05:58

Напишите программу в Python В детском садике n детей играют в следующую игру. Перед ними гора из m
кубиков, первый ребёнок вынимает из кучи 1 кубик, каждый последующий
ребёнок — в два раза больше предыдущего и так по кругу. Если число кубиков, которые нужно вынуть, превышает 25, из него вычитается 25 и отсчёт
идёт от уменьшенного числа, например, вместо 32 кубиков будет вынуто 7,
затем 14 и т. д. Проигравшим считается тот, кто не смог вытащить нужное
число кубиков (в куче осталось недостаточно). Определите проигравшего.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
larryisreallmao
13.05.2023 01:38

Программы на языке Pascal.

Ввод элементов массива с клавиатуры:

program a;

const N=10;

var m: array [1..N] of integer;

   i, max: integer;

begin

 max:= -32768;

 for i:= 1 to N

   do begin

        readln(m[i]);

        if(m[i]>max)

          then max:= m[i];

      end;

 writeln(max);

end.

Заполнение массива случайными числами:

program a;

const N=10;

var m: array [1..N] of integer;

   i, max: integer;

begin

 randomize;

 max:= -32768;

 for i:= 1 to N

   do begin

        m[i]:= random(-32768, 32767);

        if(m[i]>max)

          then max:= m[i];

      end;

 writeln(max);

end.

0,0(0 оценок)
Ответ:
Brainly223331156
13.05.2023 01:38

Код написан на Pascal (только умоляю, будь аккуратен с отступами и табуляцией). Также прикрепил вывод компилятора (красным обвёл то, что нужно именно тебе, на остальное не обращай внимания). Также код есть в текстовом фале (его тоже прикрепил):

uses crt;

const n=10;

var m : array[1..n] of integer;

i, max, max_i : integer;

begin

   for i:= 1 to n do

   begin

       m[i]:= random(-10) + 10;

       write(m[i],' ');

   end;

   max:= m[1];

   max_i:= 1;

   for i:= 1 to n do

   begin

       if (max > m[i]) then

       begin

           max:= m[i];

           max_i:= i;

       end;

   end;

   writeln();

   writeln('max = m[',max_i,']');

   writeln('max = ',max);

end.


с информатикой! Массив задан следующим образом: Const N=10; Var m : array[1..N] of integer; Найти зн
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота