dalakovadg
08.09.2021 17:40

На паскале напишите программу: Массив содержит 30 элементов, это целые числа от 2 до 5 (предположи, оценки 9А за контрольную работу по алгебре). Напишите программу, в которой объявляется этот массив, заполняется случайными числами (от 2 до 5), выводится на экран в строчку. Затем находится средний за контрольную, а также количество «5», «4», «3» и «2». Желательно вывод программы оформить примерно так: Средний : 4.25 Количество «5»: 5 Количество «4»: 10 Количество «3»: 12 Количество «2»: 3

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Эверяшка
31.05.2023 05:00
Const heigth = 10
Const width = 10

Sub Ìàêðîñ1()
    Dim Sum(heigth - 1, width - 1)
    Dim Product(heigth - 1, width - 1)
    
    For i = 0 To heigth - 1
        For j = 0 To width - 1
            Sum(i, j) = i + j
            Product(i, j) = i * j
        Next j
    Next i
    
    Call Show(Sum, 0, 0)
    Call Show(Product, 0, 12)
End Sub

Sub Show(ByRef m, dx, dy)
    For i = 0 To heigth - 1
        For j = 0 To width - 1
            ActiveSheet.Cells(dx + i + 1, dy + j + 1).Value = Hex(m(i, j))
        Next j
    Next i
End Sub
0,0(0 оценок)
Ответ:
guldana14
25.01.2020 16:06
Без проверки полагаем, что по заданным координатам точек можно построить треугольники.

//PascalABC.Net 3.0, сборка 1111
type
  Point=record
  x,y:double
  end;

function TriangleSquare(A,B,C:Point):double;
begin
  Result:=0.5*abs(A.x*(B.y-C.y)+B.x*(C.y-A.y)+C.x*(A.y-B.y))
end;

procedure GetPoint(c:char; var A:Point);
begin
  Write('Введите координаты точки ',c,': ');
  Readln(A.x,A.y)
end;

var
  A:array['A'..'F'] of Point;
  i:'A'..'F';
  s1,s2:double;
begin
  for i:='A' to 'F' do GetPoint(i,A[i]);
  s1:=TriangleSquare(A['A'],A['B'],A['C']);
  s2:=TriangleSquare(A['D'],A['E'],A['F']);
  if s1>s2 then Writeln('Площадь первого треугольника больше')
  else
    if s2>s1 then Writeln('Площадь второго треугольника больше')
    else Writeln('Площади треугольников равны')
end.

Тестовое решение:
Введите координаты точки A: -4 3.7
Введите координаты точки B: -6.3 0
Введите координаты точки C: 10.2 5.93
Введите координаты точки D: 7.143 8.1
Введите координаты точки E: -6 -3
Введите координаты точки F: 7.4 -5.7
Площадь второго треугольника больше
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота