llleeennn
16.05.2022 20:14

Доброй ночи) Составить алгоритм (блок схему) и написать программу нахождения суммы минимального и максимального чисел в одномерном массиве!Массив заполнен случайными числами!всего в массиве 30 элементов!

Ну язык Pascal

ЗАРАНЕЕ

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Olesyalesya55
19.11.2020 22:00

var

       a: array [1..30] of Integer;

       min, max: Word;

       i: Byte;

begin

       Randomize;

       

       for i := 1 to 30 do

               a[i] := Random (20000);

       

       max := a[1];

       min := a[1];

       

       for i := 2 to 30 do begin

               if a[i] > max then

                       max := a[i];

               if a[i] < min then

                       min := a[i]

       end;

       Write (min + max)              

end.    

Есть приложение FlowChart для создания блок-схем из кода, я его и использовал.    


Доброй ночи) Составить алгоритм (блок схему) и написать программу нахождения суммы минимального и ма
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота