ЕгорВанШот
18.03.2022 01:29

Напишите программирование с#(си-шарп).составить программу возведения заданного числа в третью степень, имеющую следующую закономерность: 1³=1 2³=3+5 3³=7+9+11 4³=13+15+17+19 5³=21+23+25+27+29 вот написала: using system; using system.collections.generic; using system.linq; using system.text; namespace consoleapplication11 { class program { public int getthird(int num) { int result = 0; int kv = num * num; if (num % 2 == 0) { for (int i = num/2; i > 0; { result += kv - i * 2 + 1; } for (int i = 0; i < num / 2; i++) { result += kv + i * 2 + 1; } } else { for (int i = (num - 1) / 2; i > 0 ; { result += kv - i * 2; } result += kv; for (int i = 0; i < (num - 1) / 2; i++) { result += kv + i * 2 + 2; } } return result; } static void main(string[] args) { console.writeline("введите натуральноe числo "); console.write("result="); int a = int.parse(console.; console.write("c="); int b = int.parse(console.; console.writeline("", b); console.read(); } } } исправьте ошибку

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Kfhjrhnf
10.06.2020 23:12

using System;


class Program

{

private static int GetThird(int num)

{

var result = 0;

var kv = num * num;

if (num % 2 == 0)

{

for (var i = num / 2; i > 0; i--)

{

result += kv - i * 2 + 1;

}

for (var i = 0; i < num / 2; i++)

{

result += kv + i * 2 + 1;

}

}

else

{

for (var i = (num - 1) / 2; i > 0; i--)

{

result += kv - i * 2;

}

result += kv;

for (var i = 0; i < (num - 1) / 2; i++)

{

result += kv + i * 2 + 2;

}

}

return result;

}


//оптимизированное свое решение, коротко и ясно

private static int GetThirdOptimized(int num)

{

var result = 0;

var kv = num * num - num + 1;


for (var i = 0; i < num; i++)

{

result += kv + i * 2;

}


return result;

}


private static void Main()

{

Console.WriteLine("Введите натуральноe числo ");

var i = int.Parse(Console.ReadLine());

Console.WriteLine("{0}^3 = {1} = {2} = {3}", i, i * i * i, GetThird(i), GetThirdOptimized(i));

Console.Read();

}

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота