Medvedevatanya1
07.11.2020 03:26

РЕШИТЬ В ПАСКАЛЕ Сегодня утром жюри решило добавить в вариант олимпиады еще одну, Очень Легкую Задачу. ответственный секретарь Оргкомитета напечатал ее условие в одном экземпляре, и теперь ему нужно до начала олимпиады успеть сделать еще N копий. В его распоряжении имеются два ксерокса, один из которых копирует лист за х секунд, а другой – за y. (Разрешается использовать как один ксерокс, так и оба одновременно. Можно копировать не только с оригинала, но и с копии ему выяснить, какое минимальное время для этого потребуется.

Входные данные
На вход программы поступают три натуральных числа N, x и y, разделенные пробелом (1 ≤ N ≤ 2∙108, 1 ≤ x, y ≤ 10).

Выходные данные
Выведите одно число – минимальное время в секундах, необходимое для получения N копий.

Примеры
входные данные
4 1 1
выходные данные
3
входные данные
5 1 2
выходные данные
4

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
hooh232non666
30.04.2020 15:22

Var p1,p2,p3,p4:integer;

f,s: real;

Begin

  write('Введите площадь в Га:');

  read(f); //f--сколько всего Гектар

  write('Количество учеников в 1 классе ');

  read(p1); //p1--учеников в 1 классе

  write('Количество учеников в 2 классе ');

  read(p2); //p2--учеников в 1 классе

  write('Количество учеников в 3 классе ');

  read(p3); //p--3учеников в 1 классе

  write('Количество учеников в 4 классе ');

  read(p4); //p4--учеников в 1 классе

  s := f / (p1 + p2 + p3 + p4); //s для 1 человека

  writeln('Для 1 класса ', s * p1 : 2:1, ' га.');

  writeln('Для 2 класса ', s * p2 : 2:1, ' га.');

  writeln('Для 3 класса ', s * p3 : 2:1, ' га.');

  writeln('Для 4 класса ', s * p4 : 2:1, ' га.');

End.

Объяснение: ну как так можно быть таким глупым ОДНОКЛАССНИКАМ АНТОН

0,0(0 оценок)
Ответ:
Мира2048
01.02.2020 18:28

1.)Разрешение - произведение длины на ширину картинки.

В этом случае картинка - квадрат и у него разрешение 600*600.

У этого квадрата сжали в 2 раза длину и ширину - 300*300, следовательно уменьшили его в (600*600)/(300*300)=4 раза.

С цветовой палитрой тоже все просто - берем i от исходной и i от конечной и делим их (i - степень двойки).

24/16=1,5 раза

Теперь просто находим размер конечного файла.

12/(4*1,5)=2

ответ: 2

2.) Сначала воспользуемся формулой: V = F * n * i * t1, где V - объем, F - частота дискретизации, n - количество каналов, i - глубина кодирования, t - время записи данных. Подставим все известные данные:

V = 48000 * 2 * 16 * 90 бит.

Теперь выразим время передачи из формулы V = U * t, где V - объем, U - скорость, t - время передачи.

t = V / U, подставляем данные:

Получили ответ в секундах, но нас просят указать количество минут:

t2 = 4320 / 60 = 72 минуты

ответ: 4320 секунд

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота