Dancerebuclic2017
03.05.2022 19:55

Составьте программу которая загружает из файлов и выводит на экран портреты писателей(купала. колас. быков) и зеркально отразите изображения вниз

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
алла330
05.10.2021 23:07

#include <iostream>  //подключаем библиотеки

using namespace std; //пространство имён

int main() {

 

setlocale(LC_ALL, "Russian");

 

int tableInt;  //последовательность

int x;   //икс :)

bool ZaB = true;  //бул для красоты

 

cout << "Введите переменную X: "; cin >> x;  //просим X

cout << "Введите последовательность через пробел: ";  //последовательность

 

while(cin >> tableInt)   //цикл

{

 if(ZaB)  //для красоты

 {

  cout << "Результат: ";

  ZaB = false;

 }

 if(tableInt != 0 && tableInt > x)  //вывод того, что больше

 {

  cout << tableInt << " ";  //если ноль, то конец!

 }else if(tableInt == 0)

 {

  break;

 }

}

 

return 0; //возращаем ничего

}

0,0(0 оценок)
Ответ:
DestroyMe
05.10.2021 23:07
1. 
var 
n,i,k,sum,g:integer;

begin
readln(n);
g:=n;
while n<>0 do begin
 g:= g div 10;
 k +=1;
end;

for i:=1 to k do begin
g:= n mod 10;
sum:= sum + g;
n:=n div 10;
end;
if sum> 10 then
writeln('верно')
else
('неверно');
end.

2.
var 
n,i,k,p,h,g:integer;

begin
readln(n);
g:=n;
while n<>0 do begin
 g:= g div 10;
 k +=1;
end;
p:=n mod 10;
n:=n div 10;
for i:=1 to k-1do begin
g:= n mod 10;
if g = p then
 h += 1;
n:=n div 10;
end;
writeln(h);
end.

3.
const
n=10;
var

a:array[1..n]of integer;
i,sum:integer;

begin
a[n]:=0;
for i:=1 to 9 do
readln(a[i]);

for i:=1 to n do 
 sum:=sum+a[i];
writeln(sum);
end.

4.
var

n:integer;

begin

readln(n);

while n<>0 do begin
n:=n div 10;
k += 1;
end;
if k = 4 then
writeln('число четырехзначное')
else
writeln('число не четырехзначное');
end.

5.
var

a:array[1..10]of integer;
i:byte;

begin

for i:=1 to 10 do
readln(a[i]);

for i:=1 to 10 do begin
 if a[i] = 2 then
writeln('да есть');
break;
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота