божена2006
26.04.2023 04:24

составить программу используя оператор case


составить программу используя оператор case

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
superM228228
19.11.2020 00:04

var

       k: Word;

begin

       Read (k);

       

       case k of

       0: Write ('y = 1');

       1, 2, 3: Write ('y = x');

       4: Write ('y = 4x + 5');

       5, 6, 7, 8, 9, 10: Write ('y = 2x - 1');

       else Write ('y = 3x + 1');

       end;

end.        

0,0(0 оценок)
Ответ:
1232508
19.11.2020 00:04

var

x, y: real;

K: word;

begin

writeln('Введите исходные данные:');

write('x= ');

read(x);

write('K= ');

read(K);

case K of

0: y := 1;

1..3: y := x;

4: y := 4 * x + 5;

5..10: y := 2 * x - 1;

else y := 3 * x + 1;

end;

writeln('ответ: y= ', y);

end.

// проверено в PascalABC.NET 3.4.2, сборка 1837 от 12.10.2018

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота