Какашки456
27.10.2022 17:40

Написать на питон:

С клавиатуры вводятся целые числа a и b (b > a). Написать программу,

которая выводит на экран следующую информацию:

а) n раз число k;

б) целые числа, расположенные между a и b в порядке убывания,

включая а и b;
в) сумму всех целых чисел от a до b, не включая числа a и b;
г) произведение всех целых чисел от a до b, не включая числа a и b;
д) сумму квадратов чисел от a до b, включая числа a и b;

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Fernier
08.02.2021 07:35

Пояснение:

Нам дан путь к каталогу "Системное".

C:\Информатика\Программное обеспечение\Системное.

Из этого следует, что каталог "Системное" находится в каталоге "Программное обеспечение", который в свою очередь находится в каталоге "Информатика", который находится на диске C.

Подняться на один уровень вверх - это значит перейти в католог, который находится выше выбранного нами каталога.

Спуститься же на один уровень вниз - значит перейти в каталог который находится ниже выбранного нами каталога.

Вообще все эти каталоги можно рассмотреть как корни дерева: один толстый корень (диск С) начинает разделяться на многие другие корни (каталоги).

Исходя из этих пояснений решим задание.

C:\Информатика\Программное обеспечение\Системное.

Если мы поднимаемся на один уровень вверх, значит мы переходим из каталога "Системное" в каталог который находится выше, то есть в "Программное обеспечение".

Далее мы поднимаемся ещё на один уровень вверх: переходим из каталога "Программное обеспечение" в каталог "Информатика".

Далее мы опускаемся на один уровень вниз: из каталога "Информатика" переходим в каталог "7класс". И мы ещё раз опускаемся из каталога "7класс" в файл "Задания.doc".

Нам остаётся только выписать путь из диска С в файл "Задания.doc"

C:\Информатика\7класс\Задания.doc.

Вот и всё.

C:\Информатика\7класс\Задания.doc.

Вот и всё.

Если у Вас есть вопросы по заданию - можете задать их мне.

Удачи Вам! :)

0,0(0 оценок)
Ответ:
tatiana158
23.02.2020 02:56
Var
    a: array[1..100, 1..100] of integer;
    i, j, m, n, count2, countx, x: integer;

begin
    {ввод матрицы}
    n := 10;
    
    writeln('Данные матрицы:');
    for i := 1 to n do
    begin
        for j := 1 to n do
        begin
            a[i, j] := random(200) - 100;
            write(a[i, j]:4, ' ')
        end;
        writeln;
    end;
    
    write('x = ');
    readln(x);
    count2 := 0;
    countX := 0;
    for i := 1 to n do
        for j := 1 to n do
        begin
            if a[i, j] = x then
                countX := countX + 1;
            if (a[i, j] >= 10) and (a[i, j] <= 99) and ((a[i, j] div 10 + a[i, j] mod 10) mod 2 = 0) then
                count2 := count2 + 1;
        end;
    writeln('countX = ', countX);
    writeln('count2 = ', count2);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота