kseniasmirnova3
17.03.2020 13:07

PYTHON: Клиент положил в банк сумму X. Каждый год ему начисляется процент P. Клиент хочет узнать сколько лет понадобится чтобы сумма была больше N.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Kros228volk225
06.07.2022 23:26
Const
    n = 25;

var
    a: array[1..n] of real;
    i, j: integer;
    min, max: real;
    sum, product, harmonic: real;

begin
    {ввод массива}
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        a[i] := random(40) - 20;
        write(a[i], ' ');
    end;
    writeln();
    
    {подсчет суммы и произведения и агригатов}
    sum := 0;
    for i := 1 to n do
        sum := sum + a[i];
    writeln('average = ', sum / n);
    
    {минимум и максимум}
    min := a[1];
    for i := 1 to n do
        if min > a[i] then min := a[i];
    writeln('min = ', min);
    
    {подсчет суммы и произведения и агригатов}
    sum := 0;
    for i := 1 to n do
        if i mod 2 = 0 then {если нужен фильтр}
            sum := sum + a[i];
    writeln('sum = ', sum);
end.
0,0(0 оценок)
Ответ:
Andezia
06.02.2021 02:50
Procedure TForm1.Button1Click(Sender: TObject);
var
  i1,i2,i3 : Integer;
  kk : Integer;
  Chislo : Integer;
begin
  Memo1.Clear;
  kk := 0;
  for i1 := 1 to 9 do
    for i2 := 0 to 9 do
      for i3 := 0 to 9 do
        if ( (i1<>i2) and (i1<>i3) and (i2<>i3) ) then
          if ( Frac((i1+i2+i3)/7)=0 ) then
          begin
            Chislo := i1*100 + i2*10 + i3;
            if ( Frac(Chislo/7)=0 ) then
            begin
               Memo1.Lines.Append(inttostr(Chislo));
               inc(kk);
            end;
          end;
end;


Написать программу на языке паскаль нахождения всех трехзначных чисел, у которых все цифры различны,
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота