2MaRiIa2
03.08.2021 23:18

C++ Одномерные массивы. Задача 1.1

Дан одномерный массив, состоящий из N вещественных элементов. Найти произведение элементов массива, расположенных между максимальным и минимальным элементами.

Формат входных данных
В первой строке входного файла содержится число N (1≤N≤100). Во второй строке даны N вещественных чисел через пробел. Гарантируется, что среди них только одно максимальное и одно минимальное.

Формат выходных данных
Выведите в выходной файл искомое произведение с 3 знаками после десятичной точки или 0, если между максимальным и минимальным элементом нет других элементов.

Примеры:
Вход
5
-3.12 -5.25 2.5 1.2 6
Выход
3.000
Вход
1
1.24
Выход
0.000​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Текст:');
  var c:=ReadlnChar('Буква:');
  Writeln('Буква встречается ',s.Where(p->p=c).Count,' раз(а)')
end.

Пример
Текст: а роза упала на лапу азора
Буква: а
Буква встречается 8 раз(а)

// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Текст:');
  var m:=s.MatchValues('(\w)\1{1}').Distinct;
  foreach var cc in m do s:=s.Replace(cc,cc[1]);
  s.Println
end.

Пример
Текст: стеклянный оловянный длинношеее искусство
стекляный оловяный длиношее искуство
0,0(0 оценок)
Ответ:
IgroNUB
27.10.2020 23:39
Информатика- дисциплина, изучающая структуру и общие свойства научной информации, а также закономерности её создания, преобразования, передачи и использования в различных сферах человеческой деятельности.

текстовый редактор-самостоятельная программа или компонент программного комплекса , предназначенная для создания и изменения текстовых данных вообще и текстовых файлов в частности

графический редактор- программа, осуществляющая работу с графической информацией (Штриховыми и растровыми изображениями).информатика- это знание, которые мы получаем из различных источников.
Текстовый редактор- это программа, вс которой мы можем форматировать, меня и удалять текст.
Графический- мы можем редактирывать, форматировать графические объекты.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота