ayato0haruka
14.09.2021 13:03

Составить программу нахождения площади треугольника по формуле герона. входные данные длины сторон треугольника. выходные данные периметр треугольника, площадь треугольника.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ivansndreev1223
10.06.2020 18:52

program abc;
uses crt;
var a,b,c,P,S,P2:real;
begin
writeln('Введите первую сторону: ');
readln(a);
writeln('Введите вторую сторону: ');
readln(b);
writeln('Введите третью сторону: ');
readln(c);
if (a+b<c) or (a+c<b) or (b+c<a) then
writeln('Ваш треугольник не существует')
else
P:=a+b+c;
P2:=P/2;
S:=sqrt(P2*(P2-a)*(P2-b)*(P2-c));
writeln('Периметр = ',P);
writeln('Площадь = ',S);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота