Милка98806
17.09.2022 19:03

Уровень 5 Используя графические возможности языка программирования Pascal, решите
y = 0,3х - 2),
систему уравнений
y = cos x;
Значениях находятся на промежутке [0; 20].​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
jutyra
30.01.2021 09:39

{Напишите программу, которая находит минимальное и максимальное

среди чётных положительных чисел, записанных в файле,

и выводит результат в другой файл.}

var f:text;

 min, max,a :integer;

 find:boolean;{есть/нет числа удовлетворяющие условию}

begin

 assign(f,'dan.txt'); reset(f);

 min:=0; max:=0;

 find:=false;

 while not eof(f) do

 begin

 read(f,a);

 if not find and (a>0) and (a mod 2=0) then

 begin

  min:=a; find:=true;

 end

 else

 if find and (a>0) and (a mod 2=0) and (min>a) then

  min:=a;

 if (a>0) and (a mod 2=0) and (max<a) then

  max:=a;

 end;

 close(f);

 assign(f,'res.txt');

 rewrite(f);

 if max=0 then writeln(f,'чётных положительных чисел нет')

 else

  writeln(f,'min среди чётных положительных чисел =',min, chr(13),

     'max среди чётных положительных чисел нет',max);

 close(f);

end.

Подробнее - на -

Объяснение:

0,0(0 оценок)
Ответ:
sasharyabukhina
30.01.2021 09:39
{Напишите программу, которая находит минимальное и максимальное
среди чётных положительных чисел, записанных в файле,
и выводит результат в другой файл.}
var f:text;
  min, max,a :integer;
  find:boolean;{есть/нет числа удовлетворяющие условию}
begin
 assign(f,'dan.txt'); reset(f);
 min:=0; max:=0;
 find:=false;
 while not eof(f) do
 begin
  read(f,a);
  if not find and (a>0) and (a mod 2=0) then
  begin
   min:=a; find:=true;
  end
  else
  if find and (a>0) and (a mod 2=0) and (min>a) then
   min:=a;

  if (a>0) and (a mod 2=0) and (max<a) then
   max:=a;
 end;
 close(f);
 assign(f,'res.txt');
 rewrite(f);
 if max=0 then writeln(f,'чётных положительных чисел нет')
  else
   writeln(f,'min среди чётных положительных чисел =',min, chr(13),
      'max среди чётных положительных чисел нет',max);
  close(f);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота