hjdbr
27.04.2023 02:12

Составить программу вычисления переменной X от х1 до х2 и Y от y1 до y2, используя вложенную циклическую структуру, где X – переменная внешнего цикла, Y – переменная внутреннего цикла. Организовать вывод таблицы значений. C++


Составить программу вычисления переменной X от х1 до х2 и Y от y1 до y2, используя вложенную цикличе
Составить программу вычисления переменной X от х1 до х2 и Y от y1 до y2, используя вложенную цикличе

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
aleksandrantonov
05.09.2022 11:37
Const n=15; 
var a:array[1..n] of integer;
i,s:integer; sr:real;
begin
Randomize;
writeln('Массив:');
for i:=1 to n do
 begin
 a[i]:=random(21);
 write(a[i]:3);
 end;
writeln;
s:=0;
for i:=1 to n do s:=s+a[i];
sr:=s/n;
writeln('Среднее арифметическое = ',sr:6:2);
writeln('Номера элементов, больших среднего арифметического:');
for i:=1 to n do
 if a[i]>sr then write(i:3);
writeln;
end.

Пример:
Массив:
  9 19 14 8 7 10 5 10 6 14 15 2 11 17 13
Среднее арифметическое = 10.67
Номера элементов, больших среднего арифметического:
  2 3 10 11 13 14 15
0,0(0 оценок)
Ответ:
Олька1824
23.06.2021 04:53

ОбъясОтличник

program prog;

uses crt;

var a,b,v:integer;

begin

clrscr;

write('Возраст Антона = ');

readln(a);

write('Возраст Бориса = ');

readln(b);

write('Возраст Виктора = ');

readln(v);

writeln;

if (a>b)and(a>v) then writeln('Антон старше всех.');

if (b>a)and(b>v) then writeln('Борис старше всех.');

if (v>a)and(v>b) then writeln('Виктор старше всех.');

if (a=b)and(a>v) then writeln('Антон и Борис старше Виктора');

if (a=v)and(a>b) then writeln('Антон и Виктор старше Бориса');

if (b=v)and(b>a) then writeln('Борис и Виктор старше Антона');

if (a=b)and(a=v) then writeln('Антон,Борис и Виктор одного возраста');

end.

Подробнее - на -

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота