vika220305
10.09.2022 13:12

ПАСКАЛЬ.A. Странное сравнение Ограничение времени 1 секунда
Ограничение памяти 64Mb
Ввод стандартный ввод или compare.in
Вывод стандартный вывод или compare.out
Петя и Арсений готовятся идти в первый класс. Они очень волнуются: говорят, что к первому классу дети уже должны уметь и читать и писать и считать... Друзья знают цифры. Они решили поупражняться в сравнении чисел. Только вот математику они совсем не проходили... Числа они сравнивают так: смотрят на первую цифру, у какого числа первая цифра больше, то число они и считают большим. Напишите программу, сравнивающую числа по правилам Пети и Арсения.

Формат ввода
На вход программе поступают два примера, каждый в своей строке. Пример представляет собой два числа x и y, записанные через пробел. (1 ≤ x, y ≤ 1020) Числа x и y начинаются с различных цифр.

Формат вывода
Ваша программа должна вывести в первой строке единицу или двойку для первого примера, а во второй строке единицу или двойку для второго примера. 1 надо выводить, если первое число в примере больше по правилам детей, и 2, если больше по их правилам второе число.

Пример
Ввод Вывод
265 71
35 498
2
2

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:

Объяснение:

1. Пронумеруем разряды:

3-й разряд - 4;

2-й разряд - 1;

1-й разряд - 5;

0-й разряд - 3.

4153₈=4·8³+1·8²+5·8¹+3·8⁰

2. 4153₈=4·8³+1·8²+5·8¹+3·8⁰=2048+16+40+3=2155₁₀

3. 125/8=15 (5)

15/8=1 (7)

(1)

125₁₀=175₈

4. Пронумеруем разряды:

2-й разряд - A;

1-й разряд - 6;

0-й разряд - E;

A6E₁₆=(10)(6)(14)=10·16²+6·16¹+14·16⁰

5. A6E₁₆=10·16²+6·16¹+14·16⁰=2560+96+14=2670₁₀

6. 350/16=21 (14=E)

21/16=1 (5)

(1)

350₁₀=15E₁₆

7. 247/2=123 (1)

123/2=61 (1)

61/2=30 (1)

30/2=15 (0)

15/2=7 (1)

7/2=3 (1)

3/2=1 (1)

(1)

247₁₀=11110111₂

247/8=30 (7)

30/8=3 (6)

(3)

247₁₀=367₈

247/16=7 (15=F)

(7)

247₁₀=7F₁₆

Получившиеся числа между собой равны, так как имеют одинаковое число в десятичной системе счисления.

0,0(0 оценок)
Ответ:
TANJASELIK
19.10.2022 18:17
Замечание. Так как количество вводимых чисел заранее не известно, то откроем бесконечный цикл со всегда верным условием True, но как только будет введено число 0, остановим цикл командой break.

Программа:

program z;
var k,s,x:integer;
begin
k:=0;              {начальное значение количества двузначных чисел}
s:=0;              {начальное значение суммы двузначных чисел}
while True do  {открываем бесконечный цикл}
begin
readln(x);        {вводим число х}
if x=0 then break;  {если введенное число равно 0, то остановить цикл}
if (x>9)and(x<100) then  {если число двузначное, т.е. от 10 до 99} 
    begin 
    k:=k+1;         {количество увеличиваем на 1}
    s:=s+x;         {увеличиваем предыдущее значение суммы на число х}
    end;
end;
if k=0 then writeln('NO')  {если двузначных чисел не было, то вывод NO}
   else writeln(s/k);          {иначе вывод ср.арифметического}
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота