dimonnovikov0
18.11.2022 01:13

Написать программу на С++ Дано натуральное число n. Получить все меньшие n натуральные
числа, квадрат суммы цифр которых равен некоторому заданному
числу m.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
oleg120906
22.05.2022 15:32

program Rand1;

var

 A: array [1..5] of Integer;

 i: Integer;

begin

 Randomize;

 for i := Low (A) to High (A) do begin

   A [i] := Random (3) - 1;

   WriteLn (A [i] :3)

 end;

 ReadLn;

end.

program Rand2;

var

 A: array [1..7] of Double;

 i: Integer;

begin

 Randomize;

 for i := Low (A) to High (A) do begin

   A [i] := Random (100001) / 100000 + 3;

   WriteLn (A [i] :8 :2)

 end;

 ReadLn;

end.

program Rand3;

var

 A: array [1..10] of Integer;

 i: Integer;

begin

 Randomize;

 for i := 1 to 10 do begin

   A [i] := Random (21) + 20;

   WriteLn (A [i], ' ');

 end;

 ReadLn;

end.

program Read4;

var

 A: array [1..7] of Integer;

 i: Integer;

begin

 for i := Low (A) to High (A) do begin

   Write ('Введите ', i, ' число: ');

   ReadLn (A [i]);

 end;

 for i := High (A) downto Low (A) do

   Write (A [i], ' ');

 ReadLn;

end.

0,0(0 оценок)
Ответ:
Savosin229
19.05.2023 04:45

1)

Текст состоит из K=32*32*32 символов. Каждый символ кодируется i=16 битами. Найти информационный объем текста V=?

1 символ кодируется 16 битами => 32*32*32 символа кодируются 32*32*32*16 битами => V=32*32*32*16 бит

переводим биты в килобайты:

1 байт=8 бит

1 кбайт=1024 байт=1024*8 бит

V=32*32*32*16 бит=32*32*32*16/(8*1024) кбайт=64 кбайт

ответ: 64 кбайт

2)

Файл объемом V=16 кбайт передается по некоторому каналу связи за t1=4 секунды. Найдите время передачи по этому каналу связи второго файла, объем которого равен V2=32 кбайт.

Ищем скорость передачи данных:

v=V/t1=16/4=4 кбайт/с - пропускная канала связи.

Ищем время передачи второго файла:

t2=V2/v=32 кбайт/(4 кбайт/с)=8 секунд.

ответ: 8 с

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота