321NIYAZ123
13.12.2021 22:56

вообще не понимаю подобные задачи Напишите программу, которая считывает имена двух файлов. В первом файле записан
номер координатной четверти, для которой нужно рассматривать точки, и максимальное
расстояние до подходящих точек. Во втором файле записаны координаты точекна
плоскости через пробел. Для указанной четверти выбрать точки, расстояние до которых
не превышает максимального, расположить ихв порядке убывания расстояния от начала
координат и записать кортежи ихкоординат в файл lucky. txt, каждый с новой строки.
Если расстояния одинаковы, то в порядке ввода.
Пример 1
Ввод
files/coordinate_quarter.txt
files/coordinates.txt
Вывод
(-6.0, -1.0)
(-4.0, -3.0)​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
esman2
24.09.2020 15:57

class Student():

   def __init__(self, name, adress, klass, profile, subj, raiting, teacher):

       self.name = name

       self.adress = adress

       self.klass = klass

       self.profile = profile

       self.subj = subj

       self.raiting = raiting

       self.teacher = teacher

   def print_info(self):

       print('Ім\'я учня:', self.name)

       print('Адресс:', self.adress)

       print('Класс:', self.klass)

       print('Профіль', self.profile)

       print('Предмет:', self.subj)

       print('Оцфнка:', self.raiting)

       print('Вчитель:', self.teacher, '\n')

artemenko_inf = Student('Артеменко О.П.', 'м. Київ, вул. Солом\'янська, 1', '10А', 'Гуманітарій', 'Інформатика', '10', 'Іванов І.А.')

artemenko_ukr = Student('Артеменко О.П.', 'м. Київ, вул. Солом\'янська, 1', '10А', 'Гуманітарій', 'Укр. мова', '9', 'Жук А.О.')

artemenko_fiz = Student('Артеменко О.П.', 'м. Київ, вул. Солом\'янська, 1', '10А', 'Гуманітарій', 'Фізика', '7', 'Король О.А.')

artemenko_inf.print_info()

artemenko_ukr.print_info()

artemenko_fiz.print_info()

koben_algeb = Student('Кобен С.К.', 'м. Київ, вул. Тичини, 12', '10Б', 'Фізико-математичний', 'Алгебра', '12', 'Пиріг О.Л.')

koben_inf = Student('Кобен С.К.', 'м. Київ, вул. Тичини, 12', '10Б', 'Фізико-математичний', 'Інформатика', '10', 'Іванов І.А.')

koben_ukr = Student('Кобен С.К.', 'м. Київ, вул. Тичини, 12', '10Б', 'Фізико-математичний', 'Укр. мова', '10', 'Повх А.К.')

koben_algeb.print_info()

koben_inf.print_info()

koben_ukr.print_info()

morbls_chem = Student('Морись П.З.', 'м. Київ, вул. Вишнева, 3', '10А', 'Гуманітарій', 'Хімія', '10', 'Заєць А.В.')

morbls_chem.print_info()

Объяснение:

я создал класс "ученик", с именем адресом и т.д., и потом создал переменные, которым присвоил класс "ученик" и вывел информацию о них

0,0(0 оценок)
Ответ:

Відповідь:

from random import randint as randit

lst = []

tasklst1 = 0

tasklst2 = 0

tasklst3 = 0

for elem in range(10):

   random = randit( -10, 100 )

   lst.append(random)

for i in lst:

   if i == 0:

       tasklst1 += 1

   elif i > 0:

       tasklst2 += 1

   

   elif i < 0:

       tasklst3 += 1

print("Список", lst)

print("a) У списку", len(lst), "елементів")

print("b) Середнє число у списку" , sorted(lst)[len(lst) // 2])

print("c) Сума всіх елементів" , sum(lst))

print("d) Кількість нульових елементів у масиві", tasklst1)

print("f) Максимальне число у списку", str(max(lst)) + ", мінімальне число у спику", min(lst))

print("g) Кількість додатніх елементів", tasklst2)

print("h) Кількість відємних елементів", tasklst3)

Пояснення:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота