Felipinec
22.07.2021 00:24

Составить программу:заменяющую значение любого элемента двумерного массива числом b​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
GMGasanovmm
22.07.2022 14:52

Письмо - 100 г

Посылка - 5 кг

Телеграмма - 50 г

Бандероль - 500 г

Дядя Фёдор получил:

Писем - 8 шт.

Посылок - 3 шт.

Телеграмм - 7 шт.

Бандеролей - 1 шт.

Кот Матроскин получил:

Писем - 3 шт.

Посылок - 1 шт.

Телеграмм - 3 шт.

Бандеролей - 1 шт.

Пёс Шарик получил:

Писем - 0 шт.

Посылок - 3 шт.

Телеграмм - 0 шт.

Бандеролей - 4 шт.

Вся почта, доставленная Печкиным одного вида (кол-во):

Писем - 8+3+0=11 шт.

Посылок - 3+1+3=7 шт.

Телеграмм - 7+3+0=10 шт.

Бандеролей - 1+1+4=6 шт.

Вся почта, доставленная Печкиным одного вида (вес):

Писем - 100*11=1100 г

Посылок - 5*7=35 кг

Телеграмм - 50*10=500 г

Бандеролей - 500*6=3000 г

0,0(0 оценок)
Ответ:
Treed1
19.02.2023 16:16
Традиционное решение:
var
  n,d1,d2,d3,d4:integer;
begin
  Write('Введите четырехзначное натуральное число: ');
  Readln(n);
  d1:=n div 1000; d4:=n mod 10;
  d3:=(n mod 100) div 10;
  d2:=(n mod 1000) div 100;
  n:=1000*d1+100*d3+10*d2+d4;
  Writeln('Результат: ',n)
end.

Тестовое решение:
Введите четырехзначное натуральное число: 4567
Результат: 4657

Решение с использованием символьного представления числа:
var
  s:string;
begin
  Write('Введите четырехзначное натуральное число: ');
  Readln(s);
  Writeln('Результат: ',s[1]+s[3]+s[2]+s[4])
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота