leradorozhnyak
19.04.2020 21:46

Здравствуйте решить задачу. Напишите программу, которая на вход получает координаты двух клеток шахматной доски и выводит соощение о том, являются ли эти клетки одного цвета.
Формат ввода:
c2
e4
Формат вывода:
Клетки одинакового цвета
Основное решение есть, но как преобразовать буквы в числа
d= int(input())
a= int(input())
b= int(input())
c= int(input())
if (a+b+c+d) % 2 == 0:
print('клетки одинакового цвета')

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
sashashola
11.03.2022 09:26
1)Графический редактор–это программа, предназначенная специально для рисования и редактирования изображений. Точнее, программа позволяющая вам создавать настоящие шедевры живописи прямо на вашем компьютере, или редактировать уже за ранее готовые фотографии и изображения (простой пример возможностей редактора — убрать распространенный «эффект красных глаз»).
2)Растр — изображение, построенное из отдельных элементов (точек), как правило, расположенных регулярно. В большинстве приложений компьютерной графики, растровое изображение представляется двумерным массивом точек, цвет и яркость каждой из которых задаются независимо.
Пиксел — это наименьшая единица растрового изображения, получаемого с графических систем вывода информации (компьютерные мониторы, принтеры и т. д.)
4)Графический примитив - простейший геометрический объект, отображаемый на экране дисплея или на рабочем поле графопостроителя: точка, отрезок прямой, дуга окружности или эллипса, прямоугольник и т.п.
5)Векторная графика состоит из точек линий квадратов. Качество не ухудшается при увеличении. Используется в больших плакатах, гербах...
6)Качество растрового изображения зависит от размера изображения (количества пикселей по горизонтали и вертикали) и количества цветов, которые можно задать для каждого пикселя.
7)Растровая графика позволяет создать практически любой рисунок, вне зависимости от сложности, в отличие, например, от векторной, где невозможно точно передать эффект перехода от одного цвета к другому без потерь в размере файла.
Распространённость — растровая графика используется сейчас практически везде: от маленьких значков до плакатов.
Высокая скорость обработки сложных изображений, если не нужно масштабирование.
Растровое представление изображения естественно для большинства устройств ввода-вывода графической информации, таких как мониторы (за исключением векторных устройств вывода), матричные и струйные принтеры, цифровые фотоаппараты, сканеры, а также сотовые телефоны.
0,0(0 оценок)
Ответ:
gly77oxlysj
07.02.2020 07:25
Const
 n = 20;

var
 pos,neg: integer;
 i,k,x: integer;
 ev,un: integer;
 a,b: array [1..n] of integer;

begin
 for i := 1 to n do
   read(a[i]);
  k := 0;
 pos := 0;
 neg := 0;
  for i := 1 to n do
   begin
      ev := 0;
   un := 0;
      x := a[i];
      if x <> 0 then
     if x > 0 then
       if (x < pos) or (pos = 0) then
         pos := x
       else
     else
       if (x > neg) or (neg = 0) then
         neg := x;
      x := abs(x);
      while x <> 0 do
     begin
     if odd(x) then
       un := un + 1
     else
       ev := ev + 1;
     x := x div 10
     end;
      if un = ev then
     begin
     k := k + 1;
     b[k] := a[i]
     end
      end;

 writeln(pos,' ',neg);
 for i := 1 to k do
   write(b[i],' ')
 end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота