Dikiy2004
09.04.2022 02:06

Требуется написать программу, которая выводит скорость и время движения автомобиля и выводит на экран расстояние, которое он проехал. Определите входные данные и результат этого алгоритма. К какому типу относятся входные данные:
Выберите элемент.
Сколько входных значений у алгоритма?

К какому типу относятся результаты:
Выберите элемент.
Сколько результатов у алгоритма?

Обозначьте именами входные данные и результаты и напишите их на стрелках:
алгоритм

Запишите формулу, которая связывает исходные данные и результат:

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
polonnikovdanil
13.10.2022 00:03
// PascalABC.NET 3.0, сборка 1073
const
  nn=30;
  mm=30;
var
  a:array[1..mm,1..nn] of integer;
  m,n,i,j,imax,jmax:integer;
begin
  Writeln('Введите число строк и столбцов массива: '); Read(m,n);
  Randomize;
  Writeln('*** Исходный массив ***');
  imax:=1; jmax:=1;
  for i:=1 to m do begin
    for j:=1 to n do begin
      a[i,j]:=Random(51)-25;
      Write(a[i,j]:4);
      if a[i,j]>a[imax,jmax] then
        begin imax:=i; jmax:=j end
    end;
    Writeln
  end;
  for i:=1 to m do a[i,jmax]:=0;
  for j:=1 to n do a[imax,j]:=0;
  Writeln('*** Результирующий массив ***');
  for i:=1 to m do begin
    for j:=1 to n do Write(a[i,j]:4);
    Writeln
  end
end.

Тестовое решение:
Введите число строк и столбцов массива:
5 8
*** Исходный массив ***
  11 -10 -25 -25 -19  -3  -2   0
 -24   1   5 -25 -21 -16 -16 -22
 -21 -10 -12   7  20  16   0 -10
 -13  25 -18  18  -5   9  15   1
 -19 -10 -16   9 -11  11  24 -19
*** Результирующий массив ***
  11   0 -25 -25 -19  -3  -2   0
 -24   0   5 -25 -21 -16 -16 -22
 -21   0 -12   7  20  16   0 -10
   0   0   0   0   0   0   0   0
 -19   0 -16   9 -11  11  24 -19
0,0(0 оценок)
Ответ:
korol23
21.02.2022 22:47

Основные - это те без которых он не будет работать?:

монитор - отображение видеоинформации

видеокарта - обработка и подача видеосигнала на монитор

клавиатура и мышь - ввод информации от пользователя

блок питания - распределение питания между внутренними устройствами

жёсткий диск - постоянная память компьютера

оперативная память - временная память компьютера

процессор - основные вычислительные операции

материнская плата - связыает все элементы между собой

куллер - охлаждает

системный блок - для крепления внутренних элементов

дополнительные устройства ввода: сд или двд приводы, сканер, тачпад на ноутах, сенсорные понели, вэбкамеры, микрофоны...

дополнительные устройства вывода: колонки или наушники + звуковая карта, принтеры, плоттеры, проэкторы..

устройства для коммуникаций и сетей: модемы, сетевые карты, блютус/ик платы или стационарные устройства..

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота