Лев1234567
04.10.2022 05:07

Delphi. Задан набор целых чисел. Напишите программу, которая во всех нечетных элементах заданого набора изменяет порядок цифр на противоположный. В первой строке входных данныхзаписано натуральное число N (1≤ N ≤100) - колличество чисел в наборе. Во второй строке записаны N числа. Все єти числа не превосходят 10∧9 по абсолютной величине.
Выведите состояние набора чисел после проведенной операции.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Некитсоловей
28.04.2023 22:11
#include <conio.h>
#include <iostream>
using namespace std;

int main()
{   
           int a[12],k;   
           cout<<"Massive before: ";   
           srand(time(NULL));   
           for(int i=0;i<12;i++)   
           {       
                    a[i]=(rand() % 25 -12);       
                    cout<<a[i]<<" ";       
                    if((i+1)%4==0) cout<<" | ";   
           }
           for(int j=0;j<3;j++)   
           {       
                      for(int i=0;i<2;i++)       
                      {           
                      k=a[j*4+i];           
                      a[j*4+i]=a[3+j*4-i];           
                      a[3+j*4-i]=k;       
                      }   
           }     
          cout<<endl<<"Massive       : ";   
          for(int i=0;i<12;i++)   
          {       
                       cout<<a[i]<<" ";       
                       if((i+1)%4==0) cout<<" | ";   
           }       
           getch();   
           return 0;
0,0(0 оценок)
Ответ:
ksennike
23.11.2020 20:34
Int a[50],summa=0;                                                                                                   for(int i=0;i<50;i++)                                                                                                    { a[i]=rand();                                                                                                              if(a[i]==0)  summa++;                                                                                               cout<<"Количество равно "<<summa<<"\n";                
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота