valeevinsaf
04.12.2020 16:16

Написать программу в pascalabc​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
лиза2698
13.07.2022 01:39
1. Вопрос задан коряво. Задача эта называется сундук Билли Бонса, ряд
5,2,7,9,16,25 - это пример последовательности числа монет в сундуке, если в первый год монет пять, во второй - две.
2. Вот программка на АБС-Паскале, не оптимальная по ряду моментов, но рабочая. Из особенностей - выводит решения только если если во второй год монет становится меньше, чем в первый. Существуют решения при нулевом количестве взятых во второй год монет и при отрицательном. Если такие решения нужны - то условие в  "if (j div n) < i then" надо изменить
Программка неэффективна, вместо решения диофантова уравнения по Евклиду используется тупой перебор, но по условиям он ограничен, и его можно себе позволить.
Выводятся также все решения, если нужно одно - прерывайте цикл по нахождению первого.

program БиллиБонс;
//
const
  maxYear = 20;
  maxMoney = 32767;

var
  a, b: array [1..maxYear] of integer;
  m, n, x, y: integer;
  f1, f2: text;
  s: string;

begin
 
  assign(f1, 'input.txt');   // устанавливаем связь между файловой переменной и путем к файлу
  reset(f1);  // открытие на чтение файла
  read(f1, x);
  read(f1, y);
  close(f1); // закрываем файл
 
  // Заполняем массив коэффициентов
  a[1] := 1;b[1] := 0;
  a[2] := 0;b[2] := 1;
  for var i := 3 to maxYear do
  begin
    a[i] := a[i - 1] + a[i - 2];
    b[i] := b[i - 1] + b[i - 2];
  end;
 
  m := a[x];n := b[x];
  // решаем уравнение m*s1 + n*s2 = y
  // m,n - коэффициенты, зависящие от номера года
  // s1,s2 - монет в первый и второй годы
 
  assign(f2, 'output.txt');   // устанавливаем связь между файловой переменной и путем к файлу
  rewrite(f2);  // создание (перезапись) файла
 
  for var i := 1 to y div m do
  // цикл по s1
  begin
    var j := y - m * i;
    if j mod n = 0 then
      if (j div n) < i then
      begin
        writeln('s1=', i, ' s2=', j div n);
        writeln(f2, i, ' ', j div n);  // вывод данных в файл
      end;
  end;
 
  close(f2); // закрываем файл
end.
0,0(0 оценок)
Ответ:
vadimmoroz903
23.08.2022 00:51
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrReal('Введите 4 числа:',4);
  if Frac(a.Sum/(a[3]-a[2]))=0 then Writeln('Целый результат')
  else Writeln('Нецелый результат')
end.

Примеры
Введите 4 числа: 7.2 1.8 25.5 5.5
Целый результат

Введите 4 числа: 36 18.6 12 5
Нецелый результат

Объяснения:
Первый (после begin) оператор объявляет массив из четырех вещественных элементов и заполняет его вводимыми с клавиатуры данными.
Второй делает остальное: вычисляет результат, проверяет, целочисленный ли он и выводит соответствующее сообщение на монитор.

50 решите с объяснением проверьте является ли частное от деления суммы четырех произвольных чисел, в
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота