Напишите программу Даны два числа, не равным нулю. Определить имеет ли эти числа
одинаковые знаки
Написать программу вычисления стоимости
покупки с учетом скидки Пользователь води
сумму покупки. Скидка в 3% предоставляется в
том случае, если сумма покупки больше 600 руб,
в 6% - если сумма больше 1000 руб Нуне
вывести стоимость покупки с учетом индии
Пользователь вводит число, если последняя цифра
числа меньше 5, вывести оначивается на
0,1,2,3,4», если последняя цифра чела больше или
равна 5 - вывести воначивается на 5, 6, 7, 89
Переменные ие е задаrен елучайным образом,
если сумів этих чисел четная вывее и ранее
наибольшего и наденьшего чела, если сумнів
нечетна вывести произведение не че ел​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
YummyGirl
11.11.2022 11:07
Будем последовательно решать задачу для первых i символов кода, основываясь на ответах для i - 1 и i - 2. Заметим, что если i-й символ кода равен 0 или ответа для i - 1 не существует, то ответ для i получается добавлением одного символа к ответу для i - 2, если последние две цифры кода нельзя понять, как зашифрованную букву, или ответа для i - 2 не существует, то надо добавить символ к i - 1, а иначе сравнить длины ответов и добавить букву к тому, кто короче.

Код (python 3.5):
codes = "."
with open('input.txt', 'r') as f:
    encoded = list(map(int,list(f.read(
if len(encoded) == 1:
    print(codes[encoded[0]])
else:
    decoded = [codes[encoded[0]], ""]
    for i in range(1, len(encoded)):
        if (decoded[0] is None) or (encoded[i] == 0):
            decoded = [decoded[1] + codes[10*encoded[i-1] + encoded[i]], decoded[0]]
        elif (10*encoded[i-1] + encoded[i]>26) or (decoded[1] is None) or \
            (len(decoded[1]) >= len(decoded[0])):
            decoded = [decoded[0] + codes[encoded[i]], decoded[0]]
        else:
            decoded = [decoded[1] + codes[10*encoded[i-1] + encoded[i]], decoded[0]]
    with open('output.txt', 'w') as f:
        f.write(decoded[0])
0,0(0 оценок)
Ответ:
sanyakryt
27.12.2022 08:41

Var

N,A:integer;

Begin

Write('N = ');Read(N);

A:=0;

While N>0 do

  Begin

  if (N mod 10) > A then A:= N mod 10;

  N:=N div 10;

  End;

Write(A)

End.

Var

N,A,B:integer;

C:boolean;

Begin

Write('N = ');Read(N);

A:=-1;

B:=-2;

C:=false;

While N>0 do

  Begin

  if A=B then C:=true;

  if N>0 then

     Begin

     A:=N mod 10;

     N:=N div 10;

     End;

  if A=B then C:=true;

  if N>0 then

     Begin

     B:=N mod 10;

     N:=N div 10;

     End;

  End;

if A=B then C:=true;

if C then Write('Есть')

else Write('Нет')

End.

Подробнее - на -

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота