Ксюша7970
18.04.2021 00:48

Написать программу, сведением числа и определением цифр это числа, вывести это число, определить сумму этого числа, определить количество чисел, определить произведения этого числа. Через vba

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
pandaokia
17.03.2020 19:45
Const
  m = 4;
  n = 3;

var
  a: array[1..m, 1..n] of integer;
  i, j, im, jm, mx, e: integer;

begin
  Randomize;
  mx := -1000;
  for i := 1 to m do
  begin
    for j := 1 to n do
    begin
      a[i, j] := Random(100) - 50;
      e := abs(a[i, j]);
      if mx < e then begin
        mx := e; im := i; jm := j
      end;
      write(a[i,j]:4)
    end;
    writeln
  end;
  writeln;
  writeln('Максимальный по модулю элемент a[', im, ';', jm, ']=', mx)
end.

Тестовое решение:

 -12 -36 -41
   7 -45  12
 -23  48   0
  -1  31  14

Максимальный по модулю элемент a[3;2]=48
0,0(0 оценок)
Ответ:
Полина9111111
14.04.2023 06:37
1)

program raf105;

var i,j,del:integer;

begin

for i:=10 to 99 do

begin

 del:=0;

 for j:=1 to i do

 begin

   if (i mod j)=0

     then del:= del+1;

 end;

 if del=3

   then writeln(i);

end;  

end.

2)

program raf105;

var a,b,c:integer;

x:boolean;

begin

write('Введите число: ');

readln(a);

write('Введите искомую цифру: ');

readln(c);

while a<>0 do

begin

 b:= a mod 10;

 if x=false

   then x:= b=c;

 a:= (a-b) div 10;

end;

if x

 then writeln('В ведённом числе есть искомая цифра')

 else writeln('В ведённом числе нет искомой цифры');

end.

3)

a) 2

b) 1

c) 0

d) 1

e) бесконечно

Язык программирования PascalABC

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота