mishanyak19991
17.07.2020 09:13

Напишите программу в паскале с оператором repeat дано целое число n (> 0) используя операции деления нацело и взятия остатка от деления, найти количество и сумму его цифр (n=63)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dima2845
10.06.2020 13:08

var n,l,s,k:int64;

begin

read(n);

repeat

k:=n mod 10;

s:=s+k;

l:=l+1;

n:=n div 10;

until n=0;

write(l,' ',s);

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота