Diana15080511
16.02.2023 06:01

Составить программу которая полетела в клавиатуре в строке менять символы синус на косинус? ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
biobiobio
13.02.2023 20:01

В скобках систмы счисления. 8в1 это восемь в первой степени

3.

135(8) = 5*8в0 + 3*8в1 + 1*8в2 = 5+24+64=93

4.

110001001111 = делим на тетраеды

1100  0100   1111

переводим каждую отдельно в десятичную

1100 = 0*2в0 + 0*2в1 + 1*2в2 * 1*2в3 = 0+0+4+8 = 12

12 в 16тиричной систме записывается буквой С


0100 = 0*2в0 + 0*2в1 + 1*2в2 + 0*2в3 = 0+0+4+0 = 4

в 16тиричной записывается как 4


1111 = 1*2в0 + 1*2в1 + 1*2в2 + 1*2в3 = 1+2+4+8 = 15

в 16тиричной это записывается как F

Итого число получается - С4F


5.

110001001111(2) = 1*2в0 + 1*2в1 + 1*2в2 + 1*2в3 + 1*2в6 + 1*2в10 + 1*2в11 = 1+2+4+8+64+1024+2048 = 3151



1. выполните сложение в двоичной системе счисления: 101112 + 1011102 результат запишите в двоичной с
0,0(0 оценок)
Ответ:
tfdr
07.02.2021 23:26
Задание №1
var
  x:integer;
begin
  for x:=5 to 15 do Writeln('x=',x:2,'  y=',2*x)
end.

Результат выполнения программы:
x= 5  y=10
x= 6  y=12
x= 7  y=14
x= 8  y=16
x= 9  y=18
x=10  y=20
x=11  y=22
x=12  y=24
x=13  y=26
x=14  y=28
x=15  y=30

Задание №2
var
  x:real;
begin
  x:=1;
  while x<=2 do begin
    Writeln('x=',x:4:1,'   y=',sin(3*x):8:5);
    x:=x+0.3
  end
end.

Результат выполнения программы:
x= 1.0   y= 0.14112
x= 1.3   y=-0.68777
x= 1.6   y=-0.99616
x= 1.9   y=-0.55069

Задание №3
const
  n=40;
var
  i:integer;
  a:real;
begin
  for i:=1 to n do
  begin Write('a',i,'='); Read(a); Writeln('S=',sqr(a)) end
end.

Фрагмент работы программы:
a1=2.6
S=6.76
a2=4.18
S=17.4724
a3=1
S=1
a4=17
S=289
a5=
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота